Cara Akses Server Lokal Via Jaringan Internet LENGKAP

Mengakses Server Lokal Dari Internet

Jika kamu punya server di rumah atau dikantor kamu bisa mengaksesnya dari luar menggunakan jaringan internet darimanapun dan kapanpun.

Server disini bisa berupa cctv,server website,printer,atau komputer biasa yang akan kamu akses service port nya melalui jaringan internet.

Kamu tidak memerlukan alat khusus atau settingan yang ribet agar bisa melakukan semua itu,yang kamu butuhkan adalah :

Jika kamu baru melakukan hal ini maka kamu perlu memahami beberapa hal penting agar kamu tau dan mengerti konsep dibalik semua ini.

Apa itu Server Lokal?

Lokal server adalah Komputer yang dikonfigurasi agar resourcenya dapat dimanfaatkan oleh komputer lain untuk melakukan pekerjaan (Server yang melakukan pekerjaan, Client menerima hasilnya),resource yang di share bisa berupa File,Storage,Aplikasi,Device (Printer ,scanner,kamera,dll) yang dapat digunakan oleh komputer yang ada di dalam jaringan tersebut.

Tanpa konfigurasi dan pemberian ip public/NAT pada server local ,secara default server hanya dapat diakses dari jaringan lokal dan tidak bisa diakses menggunakan jaringan internet.

Pahami Dulu Apa itu Bandwidth?

Bandwidth adalah kemampuan maximal suatu jaringan komunikasi(kabel atau wireless) untuk mengirim dan merima data dari satu titik ke lain nya melalui jaringan komputer atau internet dalam ukuran waktu yang ditentukan (biasanya detik)

Kecepatan internet yang kamu dapat tidak akan sama dengan kemampuan bandwidth jaringan lokal mu karena ISP akan membatasi bandwidth mu menggunakan router yang berfungsi sebagai bandwidth management

Bandwidth dibagi menjadi 2 yaitu bandwidth Upload dan bandwidth download:

  • Bandwidth  Upload adalah kecepatan maximal transfer ketika kamu mengirim data melelui jaringan internet.

    Bandwidth upload banyak digunakan oleh server di internet yang notabane nya mengunggah data ke internet untuk di download oleh penggunanya,seperti browsing dan streaming.

    Bandwidth upload dipakai juga oleh user biasa ketika kamu request data seperti upload foto atau video namun penggunaan nya dalam porsi sedikit.
  • Bandwidth Bownload adalah kecepatan maximal transfer data saat kamu menerima data dari internet (download).

    Bandwidth download biasa digunakan oleh pelanggan internet biasa untuk kegiatan berinternet yang notabane nya mengambil data dari internet,mulai dari browsing,nonton youtube,download aplikasi dll

Fakta Penting Bandwidth Yang Perlu Kamu Ketahui

  1. Bandwidth yang akan digunakan server adalah Bandwidth Upload bukan bandwidth download
  2. Kecepatan download komputer client yang mengakses data di servermu tidak bisa lebih dari kecepatan bandwidth upload yang kamu gunakan pada server mu

    Misal ada orang yang mengakses servermu menggunakan internet dengan kecepatan 10Mbps lalu  mengakses server mu yang hanya memiliki kecepatan Upload 2Mbps,maka kecepatan maximal download orang tersebut adalah 2Mbps atau bisa kurang tergantung kepadatan internet mu
  3. Untuk mengetest kecepatan download dan upload intenetmu bisa kamu gunakan website http://www.speedtest.net/id dan klik mulai/start . kecepatan unduh adalah banwidth download ,kecepatan unggah adalah bandwidth upload.
    car amelakukan test bandwidth internet yang kita gunakan

Kamu Perlu IP Public Dari ISP

Komputer/router harus punya IP Public sebagai syarat agar bisa tekoneksi ke internet, IP public inilah yang  digunakan oleh komputer untuk berkomunikasi dengan komputer lain dalam jaringan global dan membentuk jaringan global (Internet).

Dengan fitur NAT satu IP public yang terpasang di router bisa digunakan beramai ramai oleh komputer dengan IP private dibelakang router agar bisa mengakses internet.

Pada kasus seperti ini komputer dengan ip private yang mendapat sharing internet dari router ber IP public dengan memanfaatkan fitur NAT hanya bisa mengakses internet dan tidak bisa diakses langsung dari internet karena berada di belakang perangkat NAT seperti router.

Pastikan Kamu Mendapat IP Public dari ISP

Syarat mutlak agar server local yang kita kelola bisa diakses dari internet adalah kita memegang kendai IP Public yang dijatah dari ISP (Internet Service Privider adalah perusahaan kamu masang internet)

Perlu diperhatikan tidak semua ISP memberikan IP Publlic pada pelanggan nya ,dalam kasus ini pelanggan hanya diberikan IP private dan menggunakan Share IP Public dengan fitur NAT.

Jika agan menggunakan  Speedy maka selamat “spidi memberikan Dynamic IP Public” ke semua pelanggan nya.

IP public biasanya terpasang pada perangkat Router atau Modem yang punya fitur sekaligus router.

Cara Mengecek IP Public yang kamu Gunakan

Untuk mengecek apakah kita mendapat jatah IP public sendiri dari ISP bisa dilakukan dengan langkah berikut :

  1. Buka website http://www.cmyip.org dan lihat IP public yang tertera
    cara melihat ip public internet yang kita gunakan
  2. Login ke Modem /router  Internetmu dan cek IP WAN yang terpasang pada modem /router mu
    melihat ip public yang terpasang pada modem speedy

      “Gambar hanya ilustrasi untuk menunjukan letak informasi IP public, jadi jangan dikaitkan dengan gambar sebelum nya”
  3. Jika IP yang tertera di modem dan website http://www.cmyip.org sama maka “SELAMAT” kamu dapet jatah IP public dari ISP
    Kalo kamu menggunakan modem seluler gak perlu dicoba cara ini ya “Karena internet seluler rata-rata cuma dapet ip private”

Penggunaan IP Public Untuk Server

Syarat mutlak agar server lokal mu online dan bisa diakses dari internet adalah harus mempunyai IP public, ada 2 cara menggunakan IP public untuk server lokal mu :

  1. IP Public Dipasang Langsung Pada Server
    Jika kamu memasang langsung IP Public pada server lokal yang kamu kelola, maka penggunaan IP akan menjadi Boros (satu server satu IP,sepuluh server sepuluh IP)dan jika kamu hanya punya satu IP public maka kamu tidak bisa menggunakan untuk keperluan lain,misal memberi akses internet ke komputer lain.
  2. IP Public Dipasang Pada Router (NAT)
    IP public dipasang pada perangkat Modem (yang didalam nya sudah include router) atau pada standalone router (misal mikrotik) .

    Router inilah yang digunakan untuk mengatur sharing internet dan Port Forwarding yang memungkinkan server lokal yang kamu kelola bisa diakses dari internet.

    Penggunaan router , DNS(Domain) server dan virtual host memberikan pilihan yang flexible dan menghemat penggunaan IP Public.

DDNS Untuk Mengatasi IP Dynamic

cara kerja dynamic DNS

Jika kamu telah membaca artikel pengenalan IP public dan IP private serta jenisnya maka ada 2 jenis IP berdasarkan presistensinya yaitu  Static IP (tanpa DHCP server /manual ,walau modem direstart IP tidak berubah) dan Dynamic IP (IP otomatis didapat dari DHCP server, dan setiap modem direstart IP yang didapat berbeda).

Masalah muncul ketika kita mendapat IP dynamic yang selalu berubah,tentu akan sangat merepotkan jika harus melihat IP server terlebih dahulu setiap akan mengakses server yang kita kelola dan dalam 1 hari entah berapa kali IP berubah sehingga menjadi kendala ketika kita akan  mengakses server lokal kita dari luar menggunakan internet.

Untuk menjawab masalah tersebut maka dibuatlah terobosan Dynamic DNS.

DNS (Domain Name Service) adalah server yang tugasnya menerjemahkan domain name sebagai bentuk informasi yang mudah dihafal manusia ke dalam bentuk IP ketika kita mengakses internet.

Dynamic DNS akan mengupdate NS record pada DNS server secara berkala sesuai dengan IP Public yang kita dapat,sehingga ketika IP berubah kita tetap bisa mengakses server kita menggunakan domain yang telah kita pilih.

Dibanding kita menghafalkan IP server dalam bentuk angka Dynamic DNS memberi solusi memberikan Domain untuk server lokal kita melalui Dynamic DNS service.

Dengan Dynamic DNS sebagai pengganti IP kita bisa menggunakan domain untuk mengakses Server lokal kita misalnya : serverku.dyndns.biz

Ada beberapa provider Dynamic DNS dan menyediakan layanan gratis dengan penggunaan terbatas jika kamu pengin mencobanya sebelum membeli diantaranya :

  1. dnsdynamic.org
  2. NoIP.com
  3. changeIP.com
  4. dynu.com
  5. dyn.com
  6. dan masih banyak lagi……………..

Atau kamu bisa menggunakan layanan DDNS https://ip-dynamic.com/ milik speedy jika kamu menggunakan layanan internet indihome

Cara Setting Layanan Dynamic DNS

Agar NS record pada Dynamic DNS server sesuai dengan IP Public yang kita peroleh maka kita perlu memasang Dynamic DNS Updater , updater inilah yang akan mengecek perubahan IP public mu secara berkala.

Namun jika kamu menggunakan https://ip-dynamic.com/ (layanan DDNS milik indihome) kamu bisa abaikan langkah dibawah ini ,karena ip sudah terupdate secara otomatis dan tidak perlu setting apapun.

  1. Pada Server langsung
    Layanan Dynamic DNS menyediakan aplikasi updater baik untuk OS windows ataupun Linux. yang bisa kamu install langsung di sistem operasi server lokal yang kamu gunakan saat ini.
  2. Pada Mikrotik Router
    Mikrotik Router mendukung scripting  dan scheduling yang bisa kita manfaat kan untuk update.Script updater bisa kita cari di internet disesuaikan dengan Dynamic DNS service yang kamu gunakan,pada contoh dibawah ini saya menggunakan NOIP.

    Cara Memasang script DDNS updater: System > Script pilih tab script dan klik tanda + untuk menambahkan baru ,masukan script pada kotak Source: Berinama pada bagian name serta ganti bagian :
    :local noipuser “ganti-dengan-email-noip-mu”
    :local noippass “ganti-dengan-password-noip-mu”
    :local noiphost “serverku.hopto.org”


    Script lengkap nya bisa kamu copy paste dibawah ini :
# No-IP automatic Dynamic DNS update

#--------------- Change Values in this section to match your setup ------------------

# No-IP User account info
:local noipuser "ganti-dengan-email-noip-mu"
:local noippass "ganti-dengan-password-noip-mu"

# Set the hostname or label of network to be updated.
# Hostnames with spaces are unsupported. Replace the value in the quotations below with your host names.
# To specify multiple hosts, separate them with commas.
:local noiphost "serverku.hopto.org"

# Change to the name of interface that gets the dynamic IP address
:local inetinterface "Ganti-dengan-nama-interface-IP-public-mu-dipasang"

#------------------------------------------------------------------------------------
# No more changes need

:if ([/interface get $inetinterface value-name=running]) do={
# Get the current IP on the interface
  :local currentIP [/ip address get [find interface="$inetinterface" disabled=no] address]

# Strip the net mask off the IP address
  :for i from=( [:len $currentIP] - 1) to=0 do={
     :if ( [:pick $currentIP $i] = "/") do={ 
        :set currentIP [:pick $currentIP 0 $i]
     } 
  }

# The update URL. Note the "\3F" is hex for question mark (?). Required since ? is a special character in commands.
  :local url "http://dynupdate.no-ip.com/nic/update\3Fmyip=$currentIP"
  :local noiphostarray
  :set noiphostarray [:toarray $noiphost]
  
  :foreach host in=$noiphostarray do={
    # Check 1 - resolved IP
    :local resolvedIP [:resolve $host];

    # Check 2 - Saved response from NO-IP
    :local filename ("no-ip_ddns_update-" . $host . ".txt")
    :local savedMatch -1
    :local savedIP "No File";

    if ( [:len [/file find name=$filename]] > 0 ) do={
      :set savedIP [/file get $filename contents]
      :set savedMatch [:find $savedIP $currentIP -1]
    }

    # If either check fails, update IP	
    :if (($currentIP = $resolvedIP) && ($savedMatch >= 0)) do={
      :log info "No-IP: Host $host already on No-IP with IP $resolvedIP"
    } else={
      :log info "No-IP: Sending update for $host - $resolvedIP saved as $savedIP"
      /tool fetch url=($url . "&hostname=$host") user=$noipuser password=$noippass mode=http dst-path=$filename
      :log info "No-IP: Host $host updated on No-IP with IP $currentIP"
    }
  }
} else={
  :log info "No-IP: $inetinterface is not currently running, so therefore will not update."
}

MengExpose service dengan Port Forwarding

Setiap aplikasi server yang berjalan sebagai Daemon /Service pasti akan membuka port untuk listening  pada server, port diwakili dengan nomer dan setiap nomer port untuk setiap aplikasi server berbeda. Ada beberapa standar nomer port server  yang digunakan misalnya untuk SSH server 22, FTP server 21,Telnet Server 23,Http server 80,SSL 443  dan masihbanyak lagi.

Istilah listening adalah state/keadaan dimana aplikasi server membuka pintu masuk pada komputer server agar client bisa menggunakan service /layanan yang disediakan.

misalnya ketika kita membuka website dan mengetikan google.com maka browser akan menghubungi server dengan alamat google.com menggunakan nomer port 80 (Jika google menggunakan https /SSL biasanya request akan diredirect ke port 443) .

Jadi dalam 1 server bisa terdiri dari banyak port yang terbuka tergantung dari aplikasi server yang diinstall di server yang kita kelola.

melihat service port yang terbuka oleh service pada server

Port Forwarding Untuk Akses Server Lokal via Internet

Kita bisa mengakses Server lokal menggunakan internet yang ada dengan memanfaatkan fasilitas port forwarding /NAT .

Port forwarding pada dasarnya memforward port yang dituju oleh client yang dialamatkan ke IP public internet yang kita pakai agar diteruskan (forward) ke IP dan Port dari Server lokal kita.

cara menggunakan port forwarding pada mikrotik Router OS

Setiap Aplikasi yang berfungsi sebagai server mempunyai port tersendiri, jika server lokal kamu mempunyai beberapa aplikasi sever seperti SSH,web server,SMB dll maka kamu harus mendefinisikan forward rule untuk setiap service agar bisa diakses melalui internet.

Cara Setting Port Forwarding

Port forwarding  sudah menjadi fitur standar untuk modem sekarang, jadi setiap modem ADSL /OPTIC pasti punya fitur port forwarding .

Modem aja punya fitur ini apa lagi standalone router seperti mikrotik , pada standalone router seperti mikrotik fitur port forwarding dikenal dengan sebukan NAT (dst nat)

  1. Pada Modem ADSL
    Dianggap kamu sudah bisa mengakses modem melalui web interface dan telah login,  untuk setiap  merek modem mempunyai nama yang sedikit berbeda tetapi maksudnya sama dan letak nya pun berada di menu yang hampirsama.

    Fasilitas port forwarding biasanya berada di grup menu Advanced / WAN /NAT dan mempunyai yang berbeda-beda seperti NAT/Virtual Server/Port Forwarding .

    Kolom terpenting setelah masuk kedalam menu portforwarding adalah :
    -Port start number / dst port : listening port number pada IP public mu (tidak harus sama dengan port number server lokal mu)
    -Port end number / redirect to port : Port number server lokal mu
    -Local IP/LAN IP :IP private dari Lokal server mu
    Jika ada menu lain seperti kolom untuk mengisikan jenis service itu hanya opsional saja dan sifatnya untuk memudahkan ketika dibaca.
    cara setting port forwarding pada modem ADSL speedy
  2. Pada Router Mikrotik
    Login ke mikrotik dengan Winbox (biar mudah :D) masuk ke menu IP >Firewall>NAT
    Pada contoh berikut saya akan menbuat server ProXmoX VE dengan IP 192.168.2.2 dan port 8006 protokol yang digunakan adalah SSL/HTTPS.

    Ketika kita mengetikan https:// untuk mengakses website maka nomer port yang dituju adalah 443 jadi kita akan mengeset Start Port number/ Dst port ke 443 dan memforward nya ke ip 192.168.2.2 dengan port 8006

    Chain : dstnat  –> artinya sama aja dengan port forwarding
    – Src. Address : Biarkan saja polos atau 0.0.0.0 –> artinya semua IP komputer bole mengakses service dari server kita nanti
    -Dst. Address  : Biarkan kosong atau 0.0.0.0  –> artinya semua IP yang terpasang di interfaces router kita bisa dijadikan jalan masuk (listening) untuk mengakses service dari server kita
    -Protocol : Pilih jenis protocol yang digunakan oleh server lokal mu
    -Dst.Port : nomer port yang akan digunakan untuk listening pada IP public (Bebas pilih suka suka kamu )
    -In interface : menentukan interface yang akan digunakan untuk listening ,jika dikosongkan maka semua interface akan listeningAction : dst-nat
    To Address : Isi dengan IP private server lokal mu
    To Ports : Isi dengan nomer port yang digunakan oleh aplikasi servermu
    cara setting port forwarding pada mikrotik untk mengakses server lokal dari internet

Mencoba Akses Server Lokal via Internet

Setelah semua selesai dilakukan lakukan ping ke domain dynamic dns yang kamu gunakan, jika resolve dan ip yang tertera saat ngeping dengan IP yang terpasang di Modem/router maka settingan Dynamic DNS sudah berhasill.

Untuk mengetest service dari server lokal mu yang kamu forward menggunakan port forwarding harus dicoba dari luar jaringan server lokal mu.

Kamu bisa menggunakan proxy atau web proxy (Jika service yang kamu forward bisa diakses menggunakan web browser) ,bisa juga minta tolong sama temen dan bisa juga dicoba menggunakan internet dari modem seluler.

Asal jangan diakses dari dalam jaringan itu sendiri karena akan error (kecuali telah ditentukan listening interface dan ditentukan rule khusus pada router).

Jika kamu menggunakan proxy luar dari jaringan yang sama dengan server lokal maka secara teknis kamu mengakses server lokal mu dari luar (tidak diakses secara langsung namung muter dulu ke proxy)

Pembahasan Terkait
membuat hotspot mikrotik tanpa userman
Cara Membuat Voucher Hotspot di Mikrotik Tanpa Userman

Bagi kamu yang sedang mencari cara setting mikrotik untuk membuat hotspot sistem voucher maka ini adalah tutorial lengkap yang kamu Read more

membuat voucher wifi hotspot
Cara Membuat Voucher WiFi Hotspot Sendiri Untuk Dijual

Pengen Jual WiFi Hotspot Dengan sistem Voucher Sendiri? Kamu bisa membuat sistem wifi hotspot yang bisa kamu jual eceran menggunakan Read more

cara membuat hotspot sendiri
Cara Membuat WiFi Hotspot Dengan Mikrotik

Ini adalah tutorial cara membuat WiFi hotspot umum (tidak menggunakan sistem voucher) sebagai fasilitas gratis di kantor, sekolah, kampus, taman, Read more

pengertian firewall jenis dan fungsinya
Pengertian firewall ,jenis dan fungsi nya

A.Pengertian Firewall Sering mendengar istilah firewall? tapi gak tau apa itu firewall sebenarnya.jangan kuatir disini akan dikupas habis-habisan semua tentang Read more

Halloo, Saya Arie

Saya orang biasa seperti mu, Saya suka sekali membantu orang-orang untuk belajar. Itulah sebabnya saya membuat website ini untuk membantu orang lain sepertimu agar lebih cepat dan mudah ketika belajar di internet.

38 tanggapan pada “Cara Akses Server Lokal Via Jaringan Internet LENGKAP

  1. permisi mau nanya, saya ada buat server lokal dengan ubuntu menggunakan virtualbox cara dapat akses online gitu gimana ya ?? selain menggunakan router

    1. sayang nya belum ada cara lain selain menggunakan router.
      tapi kalau cuma mau bisa diakses dari lokal bisa diubah konfigurasi networknya menjadi bridge dibagian virtual box nya

  2. Masalah saya begini Mas.
    subdomain di hosting = cbt.smkxxx.sch.id
    Saya alihkan ke ip public dari fibernet yg dipasang mikrotik
    Lalu difordward ke ip lokal web server.
    Sudah bisa diakses via internet.
    Masalahnya url di browser akan tertulis ip publicnya (www.xxx.xxx.xxx.xxx/cbt/login.php) bukan subdomainnya (www.cbt.smkxxx.sch.id/cbt/login.php)
    Di ip>dns>static sudah dibuat resolve juga subdomain ke ip lokal server.
    Demikian, terima kasih atas jawabannya

    1. konfigurasi webservernya juga harus pake subdomain, jangan pake IP. coba cek konfigurasi webserver nya.
      di CMS juga harus diset pake subdomain yang dimaksud agar semua link yang ada di web tersebut berubah jadi subdomain, bukanlagi IP

  3. assalamualaikum, mohon pencerahannya jika ingin menonaktifkan ddns dan mengaktifkan kembali sementara gimana caranya? saya pake ddns dynamic yang dari indihome. terimnakasih master sebelumnya. mamaf saya masih pemula

  4. Saya sudah berhasil melakukan port forwarding seperti yang diajarkan di artikel ini. Terima kasih.
    Namun yang jadi permasalahan sekarang adalah Port 1194 utk openvpn tidak bisa terbuka.

    topologi sederhanya nya seperti ini :
    SERVER menggunakan proxmox kemudian install ipcop sebagai VMware. Vmware IPCOP sudah bisa dapat internet. tapi yang jadi masalah port 1194nya sekarang.
    Mohon pencerahannya. Terima kasih

    1. maaf saya disini masih gagal paham.
      saya perlu menanyakan beberapa hal sebelum saya bisa menjawab.

      1. kalau pakai proxmox kenapa diinstall vmware didalem proxmox ya?padahal vmware dan proxmox kan sama-sama hypervisor.
      2. IP public diletakan dimana? di router mikrotik atau di modem router bawaan ISP?
      3. Kamu pakai port forwarding nya pakai apa?
      4. port open vpn nya emang sebelumnya uda pernah terbuka dan work atau emang belum pernah bisa terbuka sama sekali?

  5. mohon bantuannya. modem sudah di bridge. dial PPOE di mikrotik menggunakan ip cloud. IP Publik server dengan ip cloud sudah sama. Akses local bisa, akses dari jaringan luar pakai WIFI bisa, tapi kalau pakai HP (Paket Data) gak bisa. Kira2 apa masalahnya??

    1. ip cloud disini adalah layanan DDNS (benar begitu?)
      dari info diatas yang saya tangkap:
      -ip DDNS(ip cloud) sudah sama dengan ip dynamic yang ada di router mikrotik
      -server lokal diakses dari lokal sudah bisa
      -server lokal diakses pakai jaringan wifi dari luar sudah bisa, nah ini yang saya masih ambigue.
      Dari luar yang kamu maksud disini memang dari luar jaringan mu? apa menggunakan istilah dari luar karena pake wifi.
      istilah dari luar disini seharusnya, kamu coba akses server lokal mu menggunakan domain ipcloud yang telah kamu buat dari sumber internet yang berbeda dengan internet yang dipake oleh server, bisa menggunakan HP atau Wifi Tetangga.

      SOLUSI:
      Jika memang belum diakses dari jaringan lain menggunakan internet sedangkan IP DDNS uda sama dengan ip public router maka lakukan ini
      – coba akses mikrotikmu menggunakan domain name yang telah kamu buat ip cloud (akses aja hppt service nya di port 80 default.),
      jika berhasil diakses mikrotikmu maka kesalahan ada di settingan port forwarding.
      -Jika gak bisa diakses, pastikan kamu memasukan port yang benar yang dipake sama mikrotikmu dan cek juga kalau IP yang ada diroutermu itu IP public bukan IP private.
      soalnya kalo indihome bukan paket gamer terkadang mendapatkan IP private.

      Semoga membantu

  6. Assalamaualaikum,
    saya mau bertanya soal ip forwarding tsb, di sini saya sudah mecoba cara2 tersebut, dan sukses localhost saya dapat di akses dari luar. Namun timbul kendala dimana setelah 2 hari tidak bisa diakses lagi. setelah di cek terbaca ip public terblokir karna dideteksi spam dari komputer. Saya cba setting ulang dan bisa kembali namun setelah 2 hari seperti itu kembali terblokir. Saya coba konfirmasikan ke ISP namun keterangan dari sana kendala berada pada mikrotik kami, padahal settingan mikrotik tidak ada yang di ubah.
    mohon solusi nya, terimakasih

    1. waalaikumsalam,
      kalau menggunakan IP dynamic pastikan telah menggunakan layanan DDNS, kalau pakai speedy bisa langganan fitur DDNS di https://ip-dynamic.com/, biaya tambahan nya cuman 15rebu sebulan.
      ip dynamic ditandai dengan berubahnya ip public yang ada di router setelah router restart atau diskonek dari ISP.

      anda tidak menyertakan secara lengkap, bagian mana yang anda setting ulang sehingga bisa dipake kembali.

      kuat saya duga IP yang anda pakai adalah IP dynamic, yang bisa berubah sewaktu-waktu.

      SOLUSINYA:
      – pake layanan DDNS (DYnamic DNS)
      – MInta IP public static ke ISP, ini mungkin akan dikenakan tambahan biaya

      semoga membantu ^_^

  7. Dengan fitur NAT satu IP public yang terpasang di router bisa digunakan beramai ramai oleh komputer dengan IP private dibelakang router agar bisa mengakses internet.

    ini maksudnya apa ya kak, saya gagal faham

    1. kamu harus tau konsep TCP/IP dulu biar gak gagal faham.
      baca : konsep TCP IP

      SAYA JELASKAN SINGKAT
      – Ada 2 jenis IP yang digunakan komputer yaitu IP public dan IP private/local
      -IP public dipake oleh komputer yang terkoneksi internet secara langsung dan bersifat unik, itu artinya hanya ada satu komputer yang memakai IP public tersebut di dunia ini.
      -IP private dipake oleh komputer lokal dan tidak bersifat unik, itu artinya IP lokal komputermu bisa saja sama dengan IP lokal orang lain di dunia ini. misal sama dengan sekolah mu,sama dengan teman mu, tetangga, dll.

      Penggunaan IP public ini uda diatur dan dialokasikan oleh lembaga berwenang
      Baca : perbedaan ip publc dan private

      itu artinya kalau kamu pengin konek ke internet harus punya IP public, nah IP public ini bisa kamu dapat dari ISP saat kamu langganan internet.
      dari ISP kamu hanya dikasi 1 ip public yang bisa kamu pasang di komputer agar bisa konek ke internet.

      Masalah muncul ketika di rumah mu ada leboh dari satu perangkat yang ingin kamu konekan ke internet.
      Solusinya ya itu dengan fitur NAT yang ada di router.

      Ip public nya kamu pasang di router.

      Perangkat yang lain dirumah mu cukup dipasang IP private (biasnaya dapet otomatis dari router saat konek via wifi/lan).

      perangkat dirumah mu yang akan konek ke internet akan dapet IP lokal secara otomatis saat kamu koneksin ke router via WiFi ataupun LAN.

      Jadi sekarang kamu sudah tau kan maksud dari pertanyaan mu?

      Perangkat mu sekarang bisa konek ke internet walau hanya menggunakan IP private, itu karena sudah di NAT oleh router.
      Tanpa NAT kamu hanya bisa internet di satu perangkat saja.

  8. kalau saya ada kendala, client yg satu jaringan dengan server tidak bisa akses websitenya menggunakan dns name, harus pake ip servernya . tp kalau dari luar bisa akses pakai dns nya.
    ada solusi ga pak supaya yg satu jaringan dengan server bisa akses websitenya menggunakan dns name ?

    1. di set aja di routernya agar client lokal mau akses server lokal via domain name bisa resolve ke ip lokal server.

      kalau di mikrotik bisa masuk ke menu IP >DNS > Static >
      tinggal di add aja, name isikan domain , address isikan ip lokal server

    1. caranya sudah dijelaskan diatas.
      saya cuma ngasi gambaran luasnya biar bisa di praktekan di semua kasus untuk apapun juga.

      jadi jika anda paham cara kerjanya pasti bisa juga dipraktekan untuk kasus anda. asal memenuhi kriteria yang dibutuhkan.

      SOLUSI:
      Jika uda punya domain dan hosting mending dimigrasi saja untuk aplikasi web dan database nya.
      caranya dengan menginstall nya di virtual box terlebih dahulu lalu anda bisa mengkopi database dan file aplikasi CBT untuk dipindah ke hosting anda.

      Terimakasih

  9. Assalamu`alaikum, saya udah setting ip via forwarding dengan router tenda, pake port 8094 , tapi aplikasi belum bisa akses internet , kalo pake ip private udah bisa ?

  10. Assalamualaikum..maaf nih mau nanya mas.saya kan udah daftar di ip_dynamic, tapi ip publik nya masih blm bisa diakses juga..kendala nya spertinya pada pengaturan port forwading nya..alamat ip yg di seting nya yang dari jaringan internet apa LAN Client?mkasih.

    1. waalaikumsalam.
      maaf saya gak ngerti dengan pertanyaan nya.

      biar gak salah diagnosa maka pertanyaan harus jelas, mulai dari :
      -provider internet yang digunakan
      -router yang dipake
      -service yang mau di forward.
      makasih

  11. Halo, terima kasih artikelnya sangat membantu.
    mohon masukannya.
    Saya ada web server di rumar (windows), lalu membuat NS (name server) untuk web server tersebut? terima kasih.

  12. Hi. I have checked your tembolok.id and i
    see you’ve got some duplicate content so probably it is the reason that you don’t rank high
    in google. But you can fix this issue fast. There is
    a tool that generates content like human, just search in google:
    miftolo’s tools

    1. itu karena kamu pakai komputer model baru, jadinya kamu gak bisa install windows 7 yang masuk golongan OS ketingglan jaman (sudah gak mensupport hardware baru)

      rekomendasinya adalah kamu pakai minimal windows 8.1

  13. permisi, mau tanya untuk upload website di komputer menggunakan ip publik sudah saya baca. Terimakasih ilmunya.
    Tapi kendala saya setelah melakukan dengan keadaan dimana:
    saya mempunyai ip publik melalui ISP. IP komputer lokal (server) isi source code php, xampp sudah menyala. IP komputer sudah redirect ke IP publik ISP menggunakan mikrotik.
    Sudah dapat tampil di halaman menu/tampilan awal.
    Kendalanya ketika klik pada menu lain atau link sub menu kondisi loading sangat lama dan tiba-tiba saya lihat ip berubah menjadi IP komputer lokal(server). mohon bantuannya.

    1. itu karena link yang ada di website gak ngikutin ip/domain.
      kalau kamu pakai CMS wordpress untuk website mu maka nama/domain/IP bisa diset sehingga semua URL/link yang di website akan dirubah/mengikuti alamat IP atau domain dari website mu.

  14. Saya mencoba membuat webserver sendiri, provider yang digunakan Indihome.
    Topologi yang digunakan Internet -> Modem Indihome -> Mikrotik -> jaringan lokal.
    Dari modem Indihome saya menggunakan port forwarding dengan ip -> ip server, port -> 80
    Dari mikrotik saya juga menggunakan port forwarding sesuai di artikel,
    Tab General, Chain -> dstnat, Protocol -> tcp, dst port -> 80
    Tab Action, To Addresses -> IP Server, To Ports -> 80
    Saya juga menggunakan NoIP untuk mengatasi masalah IP Public, di Mikrotik sudah saya tambahkan scheduler untuk update. DNS yang saya buat testweb.ddns.net.
    Masalahnya kalau saya akses menggunakan komputer yang tersambung langsung dengan server itu bisa, tapi begitu diakses menggunakan laptop yang terhubung ke internet (tidak tersambung ke jaringan server) tidak bisa.
    Kira-kira apa masalahnya ya

    1. untukmempersimple baiknya modem speedy dijadikan bridge, dial pppoe nya di mikrotik,ini dimaksudkan agar ip public ada di mikrotik(bukan dimodem)
      jadi kamu cukup melakukan port forwarding 1x di router mikrotik.

      tentusaja bisa mengakses dengna komputer yang tersambung langsung ke server,namanya juga uda terkonek ke lokal langsung pasti bisa.
      tantangan nya kan gimana agar servermu bisa diakses dari luar dengan ip public yang ada.

      ingat untuk mempersimple port forwarding baiknya modem dijadikan mode bridge dan dial pppoe nya di mikrotik (minta CS 147 untuk ubah ke mode bridge)
      baru lakukan setting port forwarding cukup di mikrotik saja.

      untuk mengetesnya gunakan komputer/laptop/hp yang terkoneksi internet dengan sumber internet yang berbeda dengan si server (kamu bisa pake HP yang menggunakan paket data)

Tinggalkan Balasan

Alamat email Anda tidak akan dipublikasikan. Ruas yang wajib ditandai *

Kembali ke Atas