Photo of author

ditulis oleh: Arianto

Cara Backup Mikrotik Otomatis Online & Local

dipublish pada:

kategori : Mikrotik

Suatu saat mikrotik anda pasti akan rusak, baik rusak alami atau dirusak orang/dihack.

Sebelum hal itu terjadi, backup perlu dilakukan agar anda tidak kehilangan data/settingan mikrotik.

Anda bisa melakukan backup mikrotik otomatis ke email, microSD, flashdisk,SSD secara berkala.

Teknik Pencadangan Settingan Mikrotik

Untuk melakukan backup/pencadangan settingan/konfigurasi mikrotik anda bisa memanfaatkan fitur yang terlah disediakan sesuai kebutuhan.

Menggunakan Fitur Backup

Fitur backup bisa diakses dengan perintah > system backup save dari terminal atau dengan klik tombol backup pada menu files.

Fitur ini membackup seluruh settingan/konfigurasi mikrotik anda secara otomatis ketika perintah dijalankan.

cara backup settigan mikrotik manual
backup konfigurasi mikrotik cara manual

FIle hasil backup dengan extensi *.backup tidak dapat diedit sehingga file backup hanya bisa direstore ke mikrotik dengan tipe/model yang sama.

Jika anda coba restore ke mikrotik tipe lain settingan akan berantakan , bahkan ada beberapa kasus mikrotik berjalan tidak normal.

Menggunakan fitur Export

Fitur Export memberikan anda kebebasan saat membackup settingan mikrotik.

Anda bisa meng export settingan tertentu kedalam sebuah file text yang bis anda edit dengan extensi *.rsc

File hasil export bisa anda edit dan import ke mikrotik yang beda tipe atau jenis.

cara backup settingan mikrotik dengan cara export
cara export settingan mikrotik manual

Fitur export hanya bisa dipakai dari console/terminal menggunakan perintah > xxx export file=”namafile”

dimana xxx adalah path yang akan diexport.

Jika ingin mengexport seluruh settingan maka gunakan path / sehingga perintah nya adalah > /export file=”namafile”


Cara Backup Mikrotik Otomatis ke Lokal Drive

Anda bisa membackup settingan mikrotik secara otomatis ke storage internal mikrotik ataupun external.

Saya menyarankan untuk menggunakan external storage seperti MicroSD, SSD atau flashdisk jika mikrotik anda punya port USB ataupun microSD.

Hindari backup otomatis ke internal storage karena bisa bikin mikrotik hang jika kepenuhan.

Menyiapkan Storage

Untuk storage external anda bisa menggunakan Flashdisk, SSD ataupun microSD.

Silahkan sesuaikan dengan port yang ada di mikrotik anda.

storage external mikrotik
  1. Colok/tancap storage yang akan anda pakai
  2. masuk ke menu system > disk
  3. Jika ukuran free space belum muncul/blank maka format terlebih dahulu dengan klik menu format
  4. anda bisa ubah nama dengan klik 2x pada disk name
  5. cek di menu Files, harusnya akan ada folder dengan nama disk yang anda baru setting tadi.

Jika ingin copot drive anda bisa gunakan menu eject.

Sampai langkah ini drive anda sudah siap dipakai untuk nampung hasil bakcup mikrotik otomatis.

Script Auto Backup & Export ke MicroSD

Agar kita tidak repot backup manual tiap hari, saya ada script yang bisa anda pakai agar mikrotik anda backup secara otomatis sesuai waktu yang anda mau.

# AutoBackup V.1 | Tembolok.id
# Variable storage silahkan ganti sesuai nama storage anda
:local storage "disk2";
:local jam [:pick [/system clock get time] 0 2];
:local min [:pick [/system clock get time] 3 5];
:local dtk [:pick [/system clock get time] 6 8];
:local bln [:pick [/system clock get date] 0 3];
:local tgl [:pick [/system clock get date] 4 6];
:local thn [:pick [/system clock get date] 7 11];

/export  file="$storage/backup-$tgl$bln$thn_$jam$min$dtk"
/system backup save dont-encrypt=yes name="$storage/backup-$tgl$bln$thn_$jam$min$dtk"
log warning ("SYSTEM BACKUP DIJALANKAN Pada : $tgl/$bln/$thn $jam:$min:$dtk");

Script autobackup mikrotik ini akan menghasilkan file export dengan extensi *.src dan file backup dengan extensi *.backup.

File akan disimpan otomatis di storage yang telah anda tentukan pada varible $storage

Mengatur Jadwal Autobackup & Export Mikrotik

Pasang script dibawah ini pada scheduler (system > scheduler) dengan interval yang anda mau.

Saya seting untuk backup otomatis setiap 12jam (interval ), dimulai dari jam 00.00 (start time).

Untuk variable storage, silahkan isikan dengan nama storage yang telah anda set di langkah sebelum nya.

script backup dan export settingan mikrotik otomatis ke microSD, flashdisk dan SSD external
script autobackup mikrotik ke storage

Cara Backup Mikrotik Otomatis Online ke Email

Jika mikrotik anda tidak punya port USB /micro SD, anda tetap bisa melakukan backup otomatis ke Email.

Saya menggunakan email google/Gmail, jika anda mau pake email lain juga bisa.

Menyiapkan Akun Email

Khusus untuk gmil, anda perlu membuat app password yang nantinya akan dipakai untuk login ke SMPT server GMAIL dengan lebih aman.

Password nya akan beda dengan password email.

Tapi untuk bisa pakai fitur ini anda harus aktifkan dulu fitur authentifikasi 2 langkah Gmail anda.

membuat app password gmail untuk mikrotik
membuat password app untuk mikrotik
  1. buka link https://myaccount.google.com/security?gar=1
  2. pastikan verifikasi 2 langkah/2-Step Verification sudah aktif , jika belum aktifkan dulu dan ikuti prosedurnya.
  3. klik pada app password untuk membuat password khusus yang akan kita pakai di mikrotik
  4. copy password tersebut dan paste ke notepad agar anda tidak lupa.

Setting SMTP Email di Mikrotik

Agar mikrotik bisa mengirim email maka anda perlu memasang akun SMPT Gmail yang telah anda buat tadi ke mikrotik.

  1. masuk ke menu tools > Email
  2. masukan server dan port seperti gambar dibawah ini
  3. user adalah alamat email gmail anda dan password adalah app password yang telah kita buat tadi.
  4. klik OK untuk menyimpan.
setting email google di mikrotik
memasang SMTP Gmail di mikrotik

Untuk mencoba kirim email dari mikrotik anda bisa gunakan perintah ini di terminal, ganti “to=” dengan alamat email tujuan yang valid.

/tool e-mail send to=emailmu@host.domain subject="test backup mikro
tik" from="TBID Router" body="ngetest" 
cara test kirim email dari mikrotik menggunakan terminal console
kirim email dari mikrotik terminal

Jika berhasil maka di menu “LOG” akan muncul peringatan “SENT” seperti digambar atas.

Script Auto Backup & Export ke Email

Modifikasi script dibawah ini sesuai yang anda mau, yang paling penting dan wajib diubah adalah variable “tujuan”.

Isikan dengan email yang akan anda pakai untuk menerima hasil backup otomatis.

Script ini akan mengirimkan 2 buah file dengan extensi *.backup dan *.src

Anda tidak perlu kuatir storage penuh, karena file akan dihapus otomatis setelah email berhasil dikirim.

#Script Autobackup Mikrotik ke Email V.1 | Tembolok.ID
:local identity [/system identity get name];
#setting
:local tujuan "emailmu@gmail.com";
:local subject "Backup Rutin Mikrotik $identity";
:local pesan " Email ini dikirim otomatis dari mikrotik $identity berisi file backup & export";


# Get Time
:local jam [:pick [/system clock get time] 0 2];
:local min [:pick [/system clock get time] 3 5];
:local dtk [:pick [/system clock get time] 6 8];
:local bln [:pick [/system clock get date] 0 3];
:local tgl [:pick [/system clock get date] 4 6];
:local thn [:pick [/system clock get date] 7 11];

# Set Filename
:local namafile "$identity_$tgl_$bln_$thn_$jam:$min:$dtk"

#Export
:delay 5s;
/export  file=$namafile
log warning ("SYSTEM Export DIJALANKAN Pada : $namafile");
:delay 25s;

#Backup
/system backup save dont-encrypt=yes name=$namafile
log warning ("SYSTEM BACKUP DIJALANKAN Pada : $namafile");
:delay 25s;


#Kirim Email
log warning ("mengirim email backup");
/tool e-mail send to=$tujuan subject=$subject body=$pesan file="$namafile.rsc,$namafile.backup"
:delay 90s;

#Hapus file temporary
:local namafilersc 
set namafilersc ($namafile . ".rsc")
:local namafilebackup
set namafilebackup ($namafile . ".backup")

/file remove $namafilersc
/file remove $namafilebackup

log warning ("menghapus temporary files");


Schedul Autobackup & Export Mikrotik ke Email

Agar mikrotik anda melakukan backup otomatis dan mengirimkan ke email sesuai waktu yang anda inginkan maka perlu dibuat scheduler.

  1. Masuk ke menu system > scheduler > klik tanda +
  2. start time isikan dengan jam awal mulai timer berjalan
  3. interval isikan dengan berapa lama timer hingga mengeksekusi scheduler.
  4. pada kotak on event paste script autobackup email diatas yang telah anda modifikasi.
  5. klik OK
script autobackup settingan mikrotik ke email
setting mikrotik backup otomatis ke email

Untuk mencoba anda bisa set interval ke 5 menit, jangan lupa langsung set interval ke yang anda mau setelah selesai mencoba/testing.

KESIMPULAN

Backup mikrotik wajib dan harus dilakukan dengan rutin untuk mengantisipasi hal yang tidak diinginkan.

Hasil backup wajib disimpah di media external, agar ketika mikrotik rusak file hasil backup bisa direstore ke mikrotik baru.

Untuk memudahkan pekerjaan backup anda bisa menggunakan script autobackup yang telah saya siapkan.

Script ini bisa membackup mikrotik otomatis ke storage local dan email yang cocok untuk semua tipa mikrotik yang anda punya.

Pembahasan Terkait
membuat mikrotik tidak bisa dihack
Cara Mengamankan Mikrotik Dari Hacker

Kita perlu mengamankan mikrotik agar tidak bisa dihack ketika terhubung ke jaringan internet. Hacker punya banyak cara untuk ngeHack mikrotik Read more

cara remote mikrotik online jarak jauh
Cara Remote Mikrotik Jarak jauh Lewat Internet

Ingin mikrotik anda bisa diremote jarak jauh dari luar jaringan lewat internet menggunan HP, laptop atau komputer? Maka ini adalah Read more

cara netinstall mikrotik dengan linux dan windows
Cara Install Ulang Mikrotik Dengan Netinstall | Windows & Linux

Ini adalah panduan lengkap dan praktis cara install ulang mikrotik menggunakan netinstall di windows dan linux. Netinstall ini bisa anda Read more

cara reset mikrotik semua tipe
Cara Reset Mikrotik Lengkap Untuk Semua Tipe

Ini adalah cara reset mikrotik secara hard & soft ke kondisi default/pengaturan pabrik untuk semua tipe. Saat anda lupa password, Read more

Tinggalkan komentar