Photo of author

ditulis oleh: Arianto

Script AutoLogin WMS Mikrotik |Update 2021

diperbaharui pada:

Bagi kamu yang ingin WMS bisa disharing lagi menggunakan mikrotik agar tidak putus-putus setiap 30menitan, kamu bisa menggunakan script autologin WMS ini.

Saya buatkan panduan lengkap mulai dari setting mikrotik, mengedit script autologin WMS hingga cara memasang script nya.

Dijamin work 100% jika mengikuti tutorial ini dengan benar.

Pre Installasi Script Autologin WMS

Sebelum ke inti bahasan, baiknya kamu mempersiapkan segala sesuatunya terlebih dahulu agar hasilnya sesuai dengan yang diharapkan.

Mulai dari pemilihan perangkat untuk “nembak WMS”, setting alat hingga bisa dipasang script autologin WMS dengan lancar.

Memilih Perangkat Untuk Client (CPE) WMS

Pada umumnya modem WMS sudah menggunakan stadar protokol 802.11 ac , dimana radio wireless ini beroperasi di dual band, yaitu band 2.4GHz dan 5GHz.

Itu artinya kamu bisa menggunakan radio wireless merk apapun, baik 2.4GHz ataupun 5GHz.

Tapi saya sarankan untuk menggunakan radio wireless yang minimal yang sudah standar 802.11 N, sukur-sukur mampu beli yang sudah 802.11 ac.

Sangat direkomendasikan menggunakan radio merk mikrotik

  • RBLDFG-5acD – sudah support protocol 802.11ac (Rp 800-an rebu)
  • RBLDF-5nD – masih pakai protocol 802.11 N belum AC (Rp 500-an rebu)

Kenapa saya merekomendasikan kedua alat tersebut?

  • sudah pakai OS mikrotik
  • bisa dipasang script autologin
  • kualitasnya tidak perlu dipertanyakan
  • harga murah untuk kualitas sebagus itu
  • tidak perlu alat tambahan (sudah include router OS dan WiFi )
  • Bisa disetting suka-suka (sangat flexible)

Setting Modem WMS

  • Memilih Frekuensi & channel yang sesuai
  • mematikan 2GHz

Lakukan Pengaturan/Setting Dasar Pada Mikrotik

Lakukan pengaturan dasar pada mikrotik LDF sebagai router, mulai dari update, upgrade, DNS forward, NAT, DHCP Client, Menghilangkan default conf.

untuk caraya bisa kamu lihat lengkap di artikel dibawah ini atau video youtube yang saya sertakan di artikel ini

Setting Wireles Mikrotik Agar Sukses Nembak WMS

Setelah kemu melakukan pengaturan dasar, kamu perlu melakukan pengaturan tambahan di mikrotik LDF mu,

Kamu perlu mengubah beberapa informasi, terutama dibagian wireless agar sistem WMS tidak mengenali mikrotikmu.

Perubahan yang perlu dilakukan adalah :

  • ubah mac dengan mac HP
  • ubah nama radio dengan nama/jenis HP
  • ubah system identity dengan nama/jenis HP
  • WMM enable
  • Negara indonesia
  • Mode client

Detailnya bisa kamu lihat di video youtube yang telah saya sertakan di artikel ini

Gunakan Topologi ini Saat Setting WMS

Baiknya gunakan topologi dibawah ini untuk memudahkan saat konfigurasi script WMS,

karena kamu perlu mengambil beberapa informasi dari login portal WMS untuk dipasang di script autologin.

topologi setup autologin wms biar  mudah

Membuat Script Autologin WMS di Mikrotik

Script autologin WMS tidak bisa langsung dipakai (kopi-paste) begitusaja, kamu harus melakukan penyesuaian beberapa data.

Tapi jangan kuatir, karena kamu bisa gunakan template script dibawah ini agar lebih mudah.

Cukup ubah beberpaa variable maka script WMS akan jalan 100% di mikrotik mu.

Template Script Autologin WMS

Ini adalah template script autologin WMS yang variable nya harus kamu sesuaikan dengan informasi yang ada di WMS mu,

jadi jangan asal kopi paste karena 100% akan gagal.

Copy paste script ini ke notepad agar bisa kamu edit dan nantinya dipasang di mikrotik.

Silahkan kopas script dibawah ini ke notepad atau text editor favoritmu agar nantinya mudah untuk diedit.

:local currentQueue 0;
:local nolock true;
:local gurl "https://welcome2.wifi.id";
:local guxx "http://www.msftconnecttest.com/redirect";
:local username "";
:local password "";
:local int "WMS2";
:local gwp "WAG-D1-PBR";
:local mdlan "GPON00-D1-TAK-3BSR%20pon%201/3/22/1:4090:TPNS01@WIFI.ID";
:local type "WMS";

:while (true) do={ 
 :do {
  :delay 15s;
  :if ([/ping address=8.8.8.8 count=1] = 0) do={
   :set currentQueue ($currentQueue +1);
   
   :if ($currentQueue > 3) do={
    :if (nolock) do={	
	 :set nolock false;
	 
     :global gip [/ip address get [/ip address find interface=$int] address];
     :global gip [put [:pick $gip 0 [:find $gip "/"]]];
     :global gmc  [/interface wireless get $int mac-address];   
     :global vrab "ipc=$gip&gw_id=$gwp&mac=$gmc&redirect=$guxx&wlan=$mdlan";
     :global url "$gurl/authnew/login/check_login.php\?$vrab";
     :global post "username=$username@spin2&password=$password";
   
     :if ($type = "WMS") do={
      :set username "userWMSmu"
      :set password "passWMSmu"
      :set url "$gurl/wms/auth/authnew/autologin/quarantine.php\?$vrab"
      :set post "username_=$username&username=$username.TrL1@wmslite.123456789.000&password=$password"
     };
	
     log warning ("Internet Mati Memulai Koneksi Ulang | $gip | $gmc | $type | $currentQueue"); 	
     :set currentQueue 0;
	
	 :do {
	  /interface disable $int
      :delay 15s;
      /interface enable $int
	  :delay 15s
	 } on-error={
      log warning ("Error set");
     };

     :do {
	  :local result [/tool fetch http-method=post http-data=$post url=$url http-header-field="User-Agent: Mozilla/5.0" as-value output=user];
      :if ([:find ($result->"data") "Sukses"] >= 0) do={
       log info ("WIFI Kembali Normal")
      } else={
       :if (($result->"data") = "") do={
        log info ("Wifi sudah konek");
       } else={
        log warning ($result->"data")
       };
      };
	 } on-error={
      log warning ("Error Cek Internet");
     };
	 
	 :set nolock true;
	 
	} else={
	 log warning ("Lock Proses");	 
	};
	
   };
   
  } else {
   # log info ("Wifi Normal");
   :set currentQueue 0;
  };
  
  } on-error={
   log warning ("Error big");
   :set currentQueue ($currentQueue +1);
  };
}

Script Credit to : akbaryahya https://gist.github.com/akbaryahya/c0b0d937473a757e5867134ea5532a6c

Mengedit Script Autologin WMS

Kamu harus melakukan penyesuaian data pada script autologin sesuai dengan data WMS yang kamu punya mulai dari:

  • username
  • password
  • wlanID
  • post data
  • nama WiFi interface

Semua informasi tersebut bisa di dapat di halaman login WMS dengan melihat source code nya.

#1. Konekan komputer/laptop ke WMS, bisa langsung atau lewat mikrotik seperti gambar di topologi diatas.

#2. Setelah komputer/laptop mu terkonek ke WMS silakan buka 8.8.8.8 atau google.com atau terserah website apa agar portal WMS login muncul

memunculkan halaman login WMS

#3 Setelah halaman login WMS muncul, klik kanan pilih “view page source”

cara melihat source halaman login WMS

#4 Setelah source code pada halaman login WMS terbuka, kamu bisa melakukan pengeditan

Edit beberpa parameter sesuai dengan informasi yang ada di halaman login portal WMS mu

Informasi untuk tiap orang berbeda, jadi pastikan kamu tidak asal kopas punya orang .

cara edit script autologin WMS agar berhasil dan work 100%

Memasang Script Autologin WMS di Mikrotik

Setelah script kamu edit dan sesuaikan informasinya berdasar halaman login WMS sekarang tinggal kamu pasang di mikrotik nya

#1 Buka mikrotik mu , masuk ke menu system > script

#2 Klik pada tanda + biru > beri nama script dengan “wms”, paste script yang telah kamu edit tadi di kotak bawah > klik apply > run script > ok

cara memasang script autologin WMS di mikrotik

#3 tunggu sekitar 30 detik sambil kamu lihat / buka menu log untuk melihat log script nya saat sedang bekerja.

melihat kinerja script autologin WMS menggunakan log mirotik

#4 WMS otomatis akan terkonek / autologin

Sekarang kamu gak usa kuatir dengan koneksi WMS yang selalu putus setiap 30 menit.

Dengan script autologin ini kamu gak perlu melakukan manual login.

ENJOY….

#5 Agar script ini berjalan otomatis saat router reboot, kamu perlu menambahkan scheduler yang akan dieksekusi sesaat setelah router mikrotik hidup.

:delay 15s;
/sys scr run wms

Masuk ke menu system > sheduler

masukan script diatas pada kotak on event, jangan lupa untuk mengubah start time menjadi “start up”

menambahkan scheduler agar script autologin WMS berjalan otomatis saat mikrotik mati dan hidup lagi.

Video Tutorial Cara Install Script Autologin WMS@ Youtube

Video Tuturial Cara Pasang Script Autologin WMS
Pembahasan Terkait
tutorial install UniFi controller dan cara Upgrade UniFi Controller Linux dan Windows
Cara Install dan Upgrade Unifi Controller Di Linux Dan Windows

Download Paket Installasi UniFi Controller Ubiquiti Network telah menyediakan halaman download (https://www.ubnt.com/download/unifi) yang berisi firmware,manual dan software UniFi Controller. Kamu Read more

arti nyala lampu indikator pada perangkat UniFi
Arti warna nyala lampu LED indikator pada perangkat UNIFI

LED indikator pada perangkat UniFi Semua perangkat Unifi dilengkapi dengan lampu indikator,lampu indikator ini merepresentasikan status dari unifi . lampu Read more

cara setting Ubiquiti UniFi
Cara Setting UniFi AP Menggunakan UniFi Controller

Jika kamu baru beli dan pertama kali menggunakan UniFi maka kamu perlu membaca artikel ini sampai tuntas. UniFi sangat berbeda Read more

membangun jaringan wireless RT RW NET dan ISP
Cara Membuat Jaringan Wireless RT RW Net | 2021

Ingin membuat Jaringan Wireless untuk RT RW Net/ WiFi yang bisa mencakup satu komplek , RT, RW atau Satu Desa? Read more

21 pemikiran pada “Script AutoLogin WMS Mikrotik |Update 2021”

      • maaf nanya lg ya mas, maklum newbie,
        “username_=$username&username=$username.TrL1@wmslite.123456789.000&password=$password”

        jadi disini langsung aja mas ?

        “username_=$username&username=$username&password=$password”

        Balas
        • langsung dicoba saja kak, biar tau hasilnya..

          namanya juga belajar kak.. kalo gagal coba lagi..

          sampai berhasill…

          Semangat ya.
          silakan dipahami aja panduan nya.

          uda banyak yang berhasil autologin WMS pakai tutorial ini lohh…

          Balas
  1. Mohon izin bertanya saya pengguna wms reguler,apakah script ini bisa di gunakan di mikrotik yg tidak mempunyai wlan tpi di tangkap dengan router external lalu masuk jalur LAN ke mikrotik?apa ada script khusus untuk untuk topologi tersebut?Terima Kasih sebelumnya.

    Balas
  2. kadang ada kendala kak, di lognya muncul : log warning “Lock Proses” dan autologinnya jd ndak bisa. Tapi klo saya restart RBnya nanti bisa normal lg autologinnya. kejadian seperti ini muncul saat relogin setelah diskonek.
    Lock Proses itu maksudnya apa ya kak?

    Balas
    • bisa, tinggal kolom username nya diisi sama dengan password.

      username=password.
      karena pada dasarnya WMS yang hanya pakai password saja menggunakan password sebagai username nya.

      simple nya username=password

      Balas

Tinggalkan komentar