Photo of author

ditulis oleh: Arianto

Cara Failover Mikrotik 2021 | bisa Detek Status Internet

dipublish pada:

Memahami Cara kerja & Fungsi Fail Over

Ini adalah cara failover mikrotik dengan membuat router bisa mendeteksi koneksi internet dari semua ISP yang anda pasang.

Jadi bukan hanya mendeteksi gateway yang ada diatasnya (gw isp) tapi router benar-benar mengecek status internet dari ISP tersebut.

Walau router terkoneksi ke ISP tapi jika internet dari ISP tersebut bermasalah, router mikrotik otomatis akan melakukan failover.

Apa itu failover pada jaringan ?

Failover adalah metode untuk mengalihkan traffic jaringan ke line/jalur lain ke tika jalur utama mengalami kegagalan (putus).

Kenapa perlu failover ?

Punya 2 line ISP dan sudah disetting load balance agar bisa dipakai keduanya secara bersamaan?

Tapi bagaimana jika salah satu line mati?

Tentunya loadbalance akan pincang dan membuat koneksi internet anda tersendat-sendat.

Untuk mengatasi hal ini anda perlu melakukan failover gateway.

Apa manfaat/fungsi failover ?

Fungsi failover adalah untuk mengalihkan traffic secara otomatis ke jalur backup ketika jalur utama mengalami kegagalan/ tidak ada koneksi internet.

Bagaimana cara kerja failover?

Router mikrotik akan mengecek status koneksi internet untuk setiap jalur/line dari ISP yang anda pasang.

Ketika line utama tidak ada koneksi internet maka otomatis gateway/jalur/line internet cadangan akan aftif.

Dengan begini internet anda akan tetap jalan.

Metode Failover Pada Mikrotik

Metode yang mudah dan umum dipakai untuk failover koneksi internet adalah menggunakan metode scripting dan recursive gateway.

Setiap metode failover tersebut punya kelebihan dan kekurangan nya masing-masing, jadi anda harus bijak dalam memilih.

Persiapan FailOver mikrotik

Sebelum anda praktek membuat failover di mikrotik, baiknya anda perhatikan beberapa hal kecil dibawah ini.

Hal kecil ini akan menentukan keberhasilan saat anda melakukan failover di mikrotik.

skema failover mikrotik menggunakan 2 line ISP

True Internet Failover

Failover yang akan kita buat benar-benar akan mendeteksi koneksi internet, bukan hanya mengecek gateway ISP.

Itu artinya, walau jaringan kita terkoneksi ke ISP tapi jika dari ISP tidak ada internet, maka jalur ISP tersebut dianggap down/mati.

Set Gateway Manual

Selalu ada cara termudah untuk setting, salah satunya fitur “add to default route”, dimana anda tidak perlu setting gateway secara manual.

Tapi saat anda akan membuat failover di mikrotik, pastikan satu hal….

Semua gateway harus disetting MANUAL.

Kenapa?

Jaawbnya sangat jelas,

Karena kita akan memanipulasi jalur atau route, kalau dibikin default atau otomatis gimana kita mau namipulasi untuk failover.

/ip route
add check-gateway=ping disabled=no distance=1 dst-address=\
0.0.0.0/0 gateway=192.168.90.1 scope=30 target-scope=10 \
comment=”utama”]

add check-gateway=ping disabled=no distance=2 dst-address=\
0.0.0.0/0 gateway=192.168.91.1 scope=30 target-scope=10 \
comment=”utama”]

ip 192.168.90.1 adalah ip gateeway utama, sedangkan 192.168.91.1 adalah ip gateway backup.

Interface Gateway vs IP Gateway

Dalam menentukan gateway anda bisa menggunakan IP ataupun interface.

Jika interface menggunakan PPP/dynamic maka anda bisa menggunakan interface sebagai gateway.

Tapi jika interface nya ethernet (wifi/LAN) maka anda hanya bisa menggunakan IP sebagai gateway.

walau sepele, tapi anda harus paham akan hal ini ketika akan membuat failover di mikrotik

Lokal Process Mikrotik

Kalau biasanya mikrotik hanya sebagai mediator (mak comblang) yang tugasnya menghubungkan jaringan lokal dengan internet.

Tapi terkadang mikrotik perlu mengakses internet, dalam hal ini melakukan ping ke 8.8.8.8 untuk ngetest internet jalan atau tidak.

ketika mikrotik melakukan proses untuk mengakses dunia luar, baik internet atau jaringan lokal , ini disebut dengan lokal process.

Mikrotik akan menggunakan defaut gateway untuk lokal process nya.

Terkadang kita perlu merubah routing traffic untuk lokal process mikrotik ketika akan implementasi failover.

Cara Failover Mikrotik Dengan Metode Scripting

Ini adalah cara failover di mikrotik menggunakan script.

Kita akan membuat script failover yang fungsinya untuk menonaktifkan gateway utama ketika jalur utama down dan mengaktifkan kembali gateway utama ketika normal.

Mengarahkan gateway untuk lokal process mikrotik

Untuk bisa mengetahui internet di jalur utama jalan atau tidak, maka kita perlu melakukan ping ke internet lewat jalur utama.

Bagaimana cara memastikan mikrotik menggunakan jalur utama untuk melewatkan ping?

Caranya adalah dengan membuat custom route untuk local process mikrotik

/ip route
add check-gateway=ping disabled=no distance=1 dst-address=\
8.8.8.8/32 gateway=192.168.90.1 scope=30 target-scope=10

Pada kasus ini saya akan ping ke 8.8.8.8 dari dalam router untuk mengetest koneksi internet jalur utama.

Memantau Internet Jalur Utama

Anda perlu melakukan ping setiap 5 detik ke 8.8.8.8 lewat jalur utama untuk mengecek kondisi link internet .

Tool netwatch bisa anda gunakan untuk melakukan ping otomatis.

Rencananya: ,

Setiap 5 detik router akan ping ke internet (8.8.8.8) lewat jalur utama, jika RTO/putus maka gateway akan dialihkan ke jalur 2.

Ketika jalur utama kembali normal, gateway akan dipindahkan lagi ke jalur utama.

cara failover mikrotik 2 line ISP menggunakan script dan netwatch

Membuat Script Failover

Script failover ini berfungsi untuk memindahkan gateway utama ke gateway backup ketika jalur utama putus.

Buat script dibawah ini dan simpan dengan nama failover

# nama script = failover
:if ([/ip route get [/ip route find comment=”utama”] disabled]=yes) do={/ip route enable [/ip route find comment=”utama”]} else={/ip route disable [/ip route find comment=”utama”]}

Membuat Script Kembali ke Jalur Utama

Untuk membuat mikrotik pindah ke gateway utama ketika jalur utama hidup kembali, anda perlu script dibawah ini.

Simpan script dibawah ini dengan nama BackToMain

# nama script = BackToMain
:if ([/ip route get [/ip route find comment=”utama”] disabled]=yes) do={/ip route enable [/ip route find comment=”utama”]}

Kenapa Failover dengan Scripting?

Adakalanya saat failover kita perlu melakukan hal lain, tidak hanya memindahkan gateway saja.

Misal ada rule atau mangle yang harus diubah.

Dengan metode scripting seperti ini anda lebih leluasa saat melakukan failover.

Anda bisa mebuat script untuk merubah mangle, filter, NAT dan melakukan perubahan otomatis sesukan anda saat failover berlangsung.

Cara Failover Dengan Metode Recursive Gateway

Ini adalah cara termudah melakukan failover koneksi internet di mikrotik.

tetapi cara ini hanya bisa memindahkan jalur gateway saja, dan tidak bisa melakukan hal lain jika tidak dikombinasikan dengan scripting.

Mengarahkan routing local proccess

kita tetap akan gunakan ip address milik google (8.8.8.8) untuk mengetes koneksi internet.

Routing lokal process menuju 8.8.8.8 akan kita lewatkan ke jalur utama (ISP line A)

/ip route
add check-gateway=ping disabled=no distance=1 dst-address=\
8.8.8.8/32 gateway=192.168.90.1 scope=30 target-scope=10

Membuat recursive gateway

Kita akan mengatur agar router mengecek gateway ip 8.8.8.8 yang berada di internet.

untuk bisa melakukan itu maka kita harus melakukan sedikit pengaturan di menu route.

Kita akan membuat default route dengan distance “1” , gateway 8.8.8.8 scope=30 dan target-scope=30

/ip route
add check-gateway=ping disabled=no distance=1 dst-address=\
0.0.0.0/0 gateway=8.8.8.8 scope=30 target-scope=30

Membuat backup gateway

Untuk gateway ISP Line B akan kita atur sebagai backup, disini kita hanya mengatur distance menjadi “2”

/ip route
add check-gateway=ping disabled=no distance=2 dst-address=\
8.8.8.8/32 gateway=192.168.91.1 scope=30 target-scope=10

Dengan settingan gateway seperti ini, gateway line B akan aktif otomatis ketika gateway utama tidak ada koneksi internet.

Dan menjadi tidak aktif lagi ketika gateway utama kembali normal.

KESIMPULAN

Untuk membuat backup otomatis koneksi internet di mikrotik (failover), anda bisa menggunakan 2 cara yaitu metode recursive gateway dan scripting.

Metode scripting lebih flexible karena tidak hanya bisa memanipulasi state gateway, tapi bisa melakukan apapun yang relevan agar failover berjalan dengan baik.

Metode scripting ini juga bisa mendeteksi koneksi internet yang sebenarnya (tidak hanya cek gateway diatasnya)

Sedangkan metode failover dengan recursive gateway akan mampu mendeteksi koneksi internet yang sebenarnya.

Tapi metode recursive gateway hanya bisa memindahkan jalur internet saja, tidak akan bisa memanipulasi settingan lain seperti mangle,firewall dll layaknya metode sripting.

Pembahasan Terkait
cara load balance mikrotik
Cara Load Balance Mikrotik 2 ISP atau Lebih

Cara load balance mikrotik dengan 2 ISP atau lebih untuk mendistribusikan traffic secara merata ke beberapa jalur agar lebih optimal Read more

membuat halaman isolir ppp mikrotik
Cara Membuat Halaman Isolir User PPP & IP Static Mikrotik

Anda bisa redirect pelanggan PPP (PPPoe, PPTP, OVPN, L2TP, SSTP) & IP Binding static yang telat bayar ke halaman isolir Read more

cara limit bandwidth user DHCP vpn dan hotspot mikrotik
Cara Limit Bandwidth Mikrotik Hotspot, DHCP & PPPoE

Bingung cara limit bandwidth karena IP selalu berubah? User dynamik seperti hotspot, DHCP & PPP punya cara sendiri untuk limit Read more

QoS bandwidth management
QoS Bandwidth, Internet Tetap Lancar Walau Banyak Users

Apakah users/pelanggan anda sering complain internet lemot, tidak stabil, Wa putus-putus, game ngelag, ping naik turun, nelpon wa putus putus? Read more

Tinggalkan komentar